This website applies only for Mantis 1.0.* and Mantis 1.1.*
PluginManager 0.4.0    en fr de it ru 



This plugin is used to manage the plugins configuration.

  • Manage installation/upgrade/uninstallation of plugins.
  • Possibility to create package your own plugin to share with the community.
  • Easy to install.
  • Manage language translation (if the plugin supports it).
  • Mantis 1.0.5.


  • Download the last release here. (Version 0.4.0)
  • Unzip the package into the Mantis root directory (a plugins directory is created).
  • Make sure that all the Mantis directorires (including the root directory) and files are writeable by the webserver.
  • Browse the page http://.../mantis/plugins_page.php to finish the installation.
  • Then upgrade the plugin to the last release by using the dedicated link.


Upgrade from the 0.0.x release:
  • In the custom_strings_inc.php, remove the "require" line and in the config_inc.php remove all the lines added to display a link in the menu.
  • Follow the installation instructions.
  • Feel free to go to the forum and ask more explanations.


First, you need to log on into your Mantis installation with an administrator account and then browse the page and choose the PluginManager plugin link. You must fill the following fields after selecting the project to configure the plugin:
  • Check Version: Specify if you want that the PluginManager checks the plugin version.
  • Configuration threshold (Plugin Manager): Specify the threshold needed to configure the plugin. There is one field per plugin.

Hébergeur : Morinie.Fr