Mantis

Mantis 1.1.1 & HTMLmail 0.0.4

Posted by jezdikm 
Mantis 1.1.1 & HTMLmail 0.0.4
March 12, 2008 03:34PM
Hi there,

1) THANK YOU for amazing job you do!!! Your HTMLmail plugin makes mantis really useable in our environment.

2) Few notes about our installation: As in subject - we have mantis 1.1.1 and HTML mail 0.0.4 (runing on linux/apache2/php5/mystl5)
* installation without any problem (plugin manager as well as mail plugin)
* I tried to tick "Check version" check box at plugin manager - this is causing mantis a problem - showing "variable mantis_version not defined" - Unfortunately I am not able to simulate this again
* secondly when I check this check box I am getting this mantis red text error message: "SYSTEM WARNING: Invalid argument supplied for foreach()" - this problem is reproduceable.
* even the system warnings mentioned above the plugins are working well.


Once again - THANK YOU

Cheers,
Milan
Re: Mantis 1.1.1 & HTMLmail 0.0.4
March 12, 2008 03:55PM
You only have PluginManager and HTMLmail plugins?

Vincent


Mantis: 1.1.0, 1.1.5, 1.1.1
PHP: 5.0.4
SQL: MySQL 5.0.19
OS: Linux

Please complete your signature with your environment informations.
Enable skype notification here
Re: Mantis 1.1.1 & HTMLmail 0.0.4
March 13, 2008 05:49PM
Yes, I've installed only those 2 plugins. Good to say I have patched the Mantis with patches allowing me to create tickets via email (http://www.mantisbt.org/bugs/view.php?id=4286)

Btw: the problem with showing "variable mantis_version" is occuring everytime I change any ticket. The whole red message on the top of the page is: "APPLICATION WARNING #100: Configuration option 'mantis_version' not found."

Anyway all seems to be working. I am quite busy but I'll try to have a look on it ASAP and hopefully I'll be able to tell you more soon.

Cheers,
Milan
Re: Mantis 1.1.1 & HTMLmail 0.0.4
March 13, 2008 06:06PM
one more note about mantis_version:
I think it's related to your question here: [www.mantisbt.org]

What I tried is I changed this file: <mantis>/plugins/htmlmail/core/email_api.php

I changed line 40:
if ( version_compare( config_get(&#039; .....

to

if ( version_compare( MANTIS_VERSION, ....

I am not sure if this is OK against mantis dev rules but it seems to be vorking (as far as I can test - I don&#039;t have another version than 1.1.1)

Thanks,
Milan
Re: Mantis 1.1.1 & HTMLmail 0.0.4
March 13, 2008 07:02PM
The other way is to add in the config_inc.php file the following definition:

$g_mantis_version = MANTIS_VERSION;

Vincent


Mantis: 1.1.0, 1.1.5, 1.1.1
PHP: 5.0.4
SQL: MySQL 5.0.19
OS: Linux

Please complete your signature with your environment informations.
Enable skype notification here
[New] Re: Mantis 1.1.1 & HTMLmail 0.0.4
October 02, 2012 09:13AM
unable to use notif 0.0.4 with mantis 1.2.8
Is there any way to upgrade it/
Can anyone plz help as soon as possible?

kouselia
Sorry, only registered users may post in this forum.

Click here to login



Online Users

Guests: 3
Record Number of Users: 1 on September 01, 2021
Record Number of Guests: 196 on August 22, 2021
Top Users
Hébergeur : Morinie.Fr