Mantis

Can't install Plugin Manager 0.4.0 with Mantis 1.2.3

Posted by mezitlab 
Can't install Plugin Manager 0.4.0 with Mantis 1.2.3
September 24, 2010 12:54AM
I had very same problem as others before me. I have installed properly the mantis 1.2.3 and it is worked. Then I installed the Plugin Manager 0.4.0. It said everything is OK. Then when I want "Return to Plugin Manager" I got the error:
"Fatal error: Call to undefined function plugins_pluginmanager_get_plugin_list() in /path/docroot/plugins/pluginmanager/lang_inc.php on line 23"

I have done these things twice.

Whereas the earlier comments did not help me so I did a debug in the whole mantis.
Finally I found the source of the incident.

There is an undefined or an out of sight variable: $g_absolute_path
filter_api.php::52
require_once( $g_absolute_path . 'config_filter_defaults_inc.php' );

Because did not help me to I have defined the variable in config (which has been created by mantis), I changed it:
require_once(dirname(dirname(__FILE__)).DIRECTORY_SEPARATOR.'config_filter_defaults_inc.php&#039winking smiley;

Then the error disappeared and I can use the mantis with plugin manager.
Re: Can't install Plugin Manager 0.4.0 with Mantis 1.2.3
September 30, 2010 12:07PM
Big thanks for your share.

I have same problem to you with mantis 1.2.2 and pluginmanager 4.0 and this problem can be fix with your solution ^^,
Re: Can't install Plugin Manager 0.4.0 with Mantis 1.2.3
October 11, 2010 03:42AM
For some reason the global is not in scope. I used this:

global $g_absolute_path;
require_once( $g_absolute_path.'config_filter_defaults_inc.php' );
Re: Can't install Plugin Manager 0.4.0 with Mantis 1.2.3
February 02, 2011 07:55AM
Hi,

I have exact same version of manti, but i still get lang error as above, no matter what i do....

I read through other posts and realized that pluginmanger is not updated to 1.2> version... so we cannot installed plugins manager right?

Sawan

MantisBT Version 1.2.2
Schema Version 183
Re: Can't install Plugin Manager 0.4.0 with Mantis 1.2.3
February 02, 2011 08:58AM
Yes that's right.

Vincent


Mantis: 1.1.0, 1.1.5, 1.1.1
PHP: 5.0.4
SQL: MySQL 5.0.19
OS: Linux

Please complete your signature with your environment informations.
Enable skype notification here
rVz
Re: Can't install Plugin Manager 0.4.0 with Mantis 1.2.3
May 16, 2011 02:39PM
at line 52 of file /core/filter_api.php

replace
require_once( $g_absolute_path . 'config_filter_defaults_inc.php' );

by :
#bug
#require_once( $g_absolute_path . 'config_filter_defaults_inc.php' );

require_once(dirname(dirname(__FILE__)).DIRECTORY_SEPARATOR.'config_filter_defaults_inc.php&#039winking smiley;


it worked for me


MantisBT Version 1.2.4
Schema Version 183
Re: Can't install Plugin Manager 0.4.0 with Mantis 1.2.3
August 09, 2011 09:30PM
Hi. I have simillar problem.
After adding this require_once(dirname(dirname(__FILE__)).DIRECTORY_SEPARATOR.'config_filter_defaults_inc.php&#039winking smiley; every non-admin user everywhere see

Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/www/mantisbt-1.2.6/core/access_api.php on line 580

Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/www/mantisbt-1.2.6/core/access_api.php on line 169
SYSTEM WARNING: in_array() [function.in-array]: Wrong datatype for second argument

Only administrator have no problem.
Re: Can't install Plugin Manager 0.4.0 with Mantis 1.2.3
January 08, 2013 11:36AM
I have similar issue as bartoszx !
every non-admin user got this $g_cache_access_matrix_project_ids = null
and cause the crash
Only administrator have no problem.

Let me Know if you solved the issue ?
Sorry, only registered users may post in this forum.

Click here to login



Online Users

Guests: 3
Record Number of Users: 1 on November 09, 2017
Record Number of Guests: 117 on February 24, 2019
Top Users
Hébergeur : Morinie.Fr