Mantis

[Resolved] Can't install Plugin Manager 0.4.0 with Mantis 1.2.0rc1

Posted by flint 
[Resolved] Can't install Plugin Manager 0.4.0 with Mantis 1.2.0rc1
June 24, 2009 03:49PM
I recently loaded alpha3 version of Mantis. Got the plugin manager loaded and working. Soon the MantisBt 1.2.0rc1 was available, so I loaded that and copied over the config etc. and it's working fine. I went to load the Plugin Manager 0.4.0 back in and get all green confirmations on the install, but nothing sticks.

I hit "Return to Plugin Manager" and it just seems to go through the install again, reshowing the green confirmations. I'm no expert in Linux, but I feel like I have the permissions on files/folder set writeable. But maybe not. Can someone help, and maybe give the dumbed-down instructions on what to check? Thanks.

I have Ubuntu 9.04, MantisBt 1.2.0rc1, mySQL, and Plugin Manager 0.4.0.



Edited 1 time(s). Last edit at 06/24/2009 03:51PM by flint.
Re: Can't install Plugin Manager 0.4.0 with Mantis 1.2.0rc1
June 24, 2009 04:04PM
Check that the core.php file and the custom_strings_inc.php file have been modified (at least you should see something at the end about the plugin manager).

Vincent


Mantis: 1.1.0, 1.1.5, 1.1.1
PHP: 5.0.4
SQL: MySQL 5.0.19
OS: Linux

Please complete your signature with your environment informations.
Enable skype notification here
Re: Can't install Plugin Manager 0.4.0 with Mantis 1.2.0rc1
June 24, 2009 04:29PM
I suppose the files were hidden in Linux, but from my share to Windows I saw config.php~ and custom_strings_inc.php~. These had modified info. So I went through renaming and putting them in without the "~" character.

Now the whole mantis has blown up. Default page even gives:

Fatal error: Call to undefined function plugins_pluginmanager_get_plugin_list() in /home/progs/mantis/plugins/pluginmanager/lang_inc.php on line 23

Is there maybe a newer version of plugin manager than the normal download gives you?
Re: Can't install Plugin Manager 0.4.0 with Mantis 1.2.0rc1
June 24, 2009 04:32PM
The core.php file has not been modified.

Vincent


Mantis: 1.1.0, 1.1.5, 1.1.1
PHP: 5.0.4
SQL: MySQL 5.0.19
OS: Linux

Please complete your signature with your environment informations.
Enable skype notification here
Re: Can't install Plugin Manager 0.4.0 with Mantis 1.2.0rc1
June 24, 2009 04:34PM
Take a look here

Vincent


Mantis: 1.1.0, 1.1.5, 1.1.1
PHP: 5.0.4
SQL: MySQL 5.0.19
OS: Linux

Please complete your signature with your environment informations.
Enable skype notification here
Re: Can't install Plugin Manager 0.4.0 with Mantis 1.2.0rc1
June 24, 2009 04:43PM
That core.php~ file I renamed around back to core.php had that in it. Just to be sure I copied/pasted and get the same error result as above. Here's the bottom section of my core.php file:

// set HTTP response headers
http_all_headers();

// push push default language to speed calls to lang_get
if ( !isset( $g_skip_lang_load ) ) {
lang_push( lang_get_default() );
}

# signal plugins that the core system is loaded
event_signal( 'EVENT_CORE_READY' );

if ( file_exists( dirname( __FILE__ ) . DIRECTORY_SEPARATOR . 'plugins' . DIRECTORY_SEPARATOR . 'pluginmanager' . DIRECTORY_SEPARATOR . 'core.php' ) ) {
require_once( dirname( __FILE__ ) . DIRECTORY_SEPARATOR . 'plugins' . DIRECTORY_SEPARATOR . 'pluginmanager' . DIRECTORY_SEPARATOR . 'core.php' );
$g_plugins_manager_core = ON;
}
?>



Also here is my customer_strings_inc.php:

<?php
if ( file_exists( dirname( __FILE__ ) . DIRECTORY_SEPARATOR . &#039;plugins&#039; . DIRECTORY_SEPARATOR . &#039;pluginmanager&#039; . DIRECTORY_SEPARATOR . &#039;lang_inc.php&#039; ) ) {
require( dirname( __FILE__ ) . DIRECTORY_SEPARATOR . &#039;plugins&#039; . DIRECTORY_SEPARATOR . &#039;pluginmanager&#039; . DIRECTORY_SEPARATOR . &#039;lang_inc.php&#039; );
global $g_plugins_manager_lang;
$g_plugins_manager_lang = ON;
}
?>


And thanks Vincent for your quick responses.
Re: Can't install Plugin Manager 0.4.0 with Mantis 1.2.0rc1
July 03, 2009 03:08PM
1.- install mantis 1.2.0rc1 --> ok, i connect to the system ok with administrator/root
2.- copy and unzip pluginmanager-0.4.0.tar.gz in root directory
3.- enable permisions for www-data (writable)
4.- [...]
5.- all is ok
6. verify the created file custom_strings_inc.php with:
<?php
if ( file_exists( dirname( __FILE__ ) . DIRECTORY_SEPARATOR . &#039;plugins&#039; . DIRECTORY_SEPARATOR . &#039;pluginmanager&#039; . DIRECTORY_SEPARATOR . &#039;lang_inc.php&#039; ) ) {
require( dirname( __FILE__ ) . DIRECTORY_SEPARATOR . &#039;plugins&#039; . DIRECTORY_SEPARATOR . &#039;pluginmanager&#039; . DIRECTORY_SEPARATOR . &#039;lang_inc.php&#039; );
global $g_plugins_manager_lang;
$g_plugins_manager_lang = ON;
}
?>
7.- verify the added informations at the end of the file core.php
<?php
if ( file_exists( dirname( __FILE__ ) . DIRECTORY_SEPARATOR . &#039;plugins&#039; . DIRECTORY_SEPARATOR . &#039;pluginmanager&#039; . DIRECTORY_SEPARATOR . &#039;core.php&#039; ) ) {
require_once( dirname( __FILE__ ) . DIRECTORY_SEPARATOR . &#039;plugins&#039; . DIRECTORY_SEPARATOR . &#039;pluginmanager&#039; . DIRECTORY_SEPARATOR . &#039;core.php&#039; );
$g_plugins_manager_core = ON;
}
?>


but, i try to connect to [server] and ....

Fatal error: Call to undefined function plugins_pluginmanager_get_plugin_list() in /var/www/mantis/plugins/pluginmanager/lang_inc.php on line 23

but, i try to connect to [server] and ....

Fatal error: Call to undefined function plugins_pluginmanager_get_plugin_list() in /var/www/mantis/plugins/pluginmanager/lang_inc.php on line 23

any ideas ???
Re: Can't install Plugin Manager 0.4.0 with Mantis 1.2.0rc1
July 03, 2009 03:34PM
Take a look in your database (SQL) and check that there are tables named like "mantis_plugins_pm_*". If no, the installation failed, if yes make sure the tables are not empty.

Vincent


Mantis: 1.1.0, 1.1.5, 1.1.1
PHP: 5.0.4
SQL: MySQL 5.0.19
OS: Linux

Please complete your signature with your environment informations.
Enable skype notification here
Re: Can't install Plugin Manager 0.4.0 with Mantis 1.2.0rc1
July 06, 2009 04:03PM
My situation matches charsy. My database has 3 tables by that name. The dependencies table has 1 record, the mantis_plugins_pm_function_overwrite_table has no records, and the list_table has 3 records. But I&#039;m still having the same result as charsy shows.

For the moment I have renamed custom_strings_inc.php to something else to keep the program working without the plugin manager.
Re: Can't install Plugin Manager 0.4.0 with Mantis 1.2.0rc1
July 08, 2009 08:45AM
mantis_plugins_pm_dependencies_table --> no records
mantis_plugins_pm_function_overwrite_table --> no records

mantis_plugins_pm_list_table --> 1 record -->
plugin installed
pluginmanager 1
Re: Can't install Plugin Manager 0.4.0 with Mantis 1.2.0rc1
July 09, 2009 09:43AM
For the moment I have renamed custom_strings_inc.php too.
But the plugins dont work.

If someone know the solution, please, write here.

thks
Re: Can't install Plugin Manager 0.4.0 with Mantis 1.2.0rc1
July 09, 2009 02:45PM
hallo,
just install Plugin Manager 0.4.0 on Mantis 1.2.0rc1.
after the page with all the green confirmations I hit the return button and i received the following error:
Parse error: syntax error, unexpected &#039;<&#039; in C:\wamp\www\mantisbt-1.2.0rc1\core.php on line 261

mantis is no more avalable. looking at the previous messages I&#039;ve checked the core.php file and below there&#039;s the result.
could you please help in restore the functionality of Mantis ?
thanks a lot in avdance

?php
if ( file_exists( dirname( __FILE__ ) . DIRECTORY_SEPARATOR . &#039;plugins&#039; . DIRECTORY_SEPARATOR . &#039;pluginmanager&#039; . DIRECTORY_SEPARATOR . &#039;core.php&#039; ) ) {
require_once( dirname( __FILE__ ) . DIRECTORY_SEPARATOR . &#039;plugins&#039; . DIRECTORY_SEPARATOR . &#039;pluginmanager&#039; . DIRECTORY_SEPARATOR . &#039;core.php&#039; );
$g_plugins_manager_core = ON;
}
?>
Re: Can't install Plugin Manager 0.4.0 with Mantis 1.2.0rc1
July 09, 2009 02:55PM
Add a &#039;<&#039; before &#039;?php&#039;.

Vincent


Mantis: 1.1.0, 1.1.5, 1.1.1
PHP: 5.0.4
SQL: MySQL 5.0.19
OS: Linux

Please complete your signature with your environment informations.
Enable skype notification here
Re: Can't install Plugin Manager 0.4.0 with Mantis 1.2.0rc1
July 09, 2009 03:09PM
thanks Vincent,
the < there&#039;s already, I lose a char in the cut&paste operation.

<?php
if ( file_exists( dirname( __FILE__ ) . DIRECTORY_SEPARATOR . &#039;plugins&#039; . DIRECTORY_SEPARATOR . &#039;pluginmanager&#039; . DIRECTORY_SEPARATOR . &#039;core.php&#039; ) ) {
require_once( dirname( __FILE__ ) . DIRECTORY_SEPARATOR . &#039;plugins&#039; . DIRECTORY_SEPARATOR . &#039;pluginmanager&#039; . DIRECTORY_SEPARATOR . &#039;core.php&#039; );
$g_plugins_manager_core = ON;
}
?>
Re: Can't install Plugin Manager 0.4.0 with Mantis 1.2.0rc1
July 09, 2009 03:36PM
ok , due to the factI&#039;m a stupid guy I&#039;ve just cut the last part of the core.php file .
and even if I&#039;ve already paste it again inside , calling for Mantis now I received a new error:


Fatal error: Call to undefined function plugins_pluginmanager_get_plugin_list() in C:\wamp\www\mantisbt-1.2.0rc1\plugins\pluginmanager\lang_inc.php on line 23

is the re- installation the only way I have to escape from this problem ?
thanks again and srry for bother

MANTIS : 1.2.0rc1
SQL: mysql-3.23.53-win
PHP: PHP 4.3.2
WampServer2.0c
OS : Win XP
Re: Can't install Plugin Manager 0.4.0 with Mantis 1.2.0rc1
July 09, 2009 05:13PM
I&#039;m sorry but you will have to wait until I install this new release on my computer.

Vincent


Mantis: 1.1.0, 1.1.5, 1.1.1
PHP: 5.0.4
SQL: MySQL 5.0.19
OS: Linux

Please complete your signature with your environment informations.
Enable skype notification here
Re: Can't install Plugin Manager 0.4.0 with Mantis 1.2.0rc1
July 10, 2009 11:43AM
thanks Vincent.
now I installed the 1.1.8 and everything is perfect with the plugin manager and so on .
however I hope you have the chance to solve it also on the rc version because i really prefer the new interface.
thanks again

MANTIS : 1.2.0rc1
SQL: mysql-3.23.53-win
PHP: PHP 4.3.2
WampServer2.0c
OS : Win XP
Re: Can't install Plugin Manager 0.4.0 with Mantis 1.2.0rc1
September 30, 2010 12:11PM
i think you have the same problem with me.

try this [forum.morinie.fr]
Re: Can't install Plugin Manager 0.4.0 with Mantis 1.2.0rc1
May 18, 2013 09:48PM
Final fix when plugin does not work with this error:

Fatal error: Call to undefined function plugins_pluginmanager_get_plugin_list() in C:\wamp\www\mantisbt-1.2.0rc1\plugins\pluginmanager\lang_inc.php on line 23

change the entry at the bottom of the custom_strings_inc.php to be a require_once instead of require

Mine worked

Regards,
Barb Wheeler
Sorry, only registered users may post in this forum.

Click here to login



Online Users

Guests: 4
Record Number of Users: 1 on November 09, 2017
Record Number of Guests: 117 on February 24, 2019
Top Users
Hébergeur : Morinie.Fr